Sound Blaster Command App requires a device running iOS 5.0 or later, or an Android device running Android 2.2 and above.

DOWNLOAD AND INSTALL Sound Blaster Command APP TO YOUR MOBILE PHONE

Use these links to install the Sound Blaster Command App.

Super X-Fi Apps

  App Store
PlayStore